GitHub Advisoryadvisory · Maven

GHSA-69cc-cv78-qc8g Apache Tomcat: Configured cipher preference order not preserved

HIGH Published 2026-04-09 Modified 2026-05-20 Official page ↗
Aliases
CVE-2026-29129
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-coyote, org.apache.tomcat:tomcat, org.apache.tomcat.embed:tomcat-embed-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-327
Reviewed
2026-04-10

Affected packages

• Maven org.apache.tomcat:tomcat-coyote: >= 9.0.114, < 9.0.116 → fixed in 9.0.116 • Maven org.apache.tomcat:tomcat-coyote: >= 10.1.51, < 10.1.53 → fixed in 10.1.53 • Maven org.apache.tomcat:tomcat-coyote: >= 11.0.16, < 11.0.20 → fixed in 11.0.20 • Maven org.apache.tomcat:tomcat: >= 9.0.114, < 9.0.116 → fixed in 9.0.116 • Maven org.apache.tomcat:tomcat: >= 10.1.51, < 10.1.53 → fixed in 10.1.53 • Maven org.apache.tomcat:tomcat: >= 11.0.16, < 11.0.20 → fixed in 11.0.20 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.114, < 9.0.116 → fixed in 9.0.116 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.51, < 10.1.53 → fixed in 10.1.53 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.16, < 11.0.20 → fixed in 11.0.20

Description

Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Related

Alias · CVE (1)

  • CVE-2026-29129 Configured cipher preference order not preserved vulnerability in Apache Tomcat. vulnerability

Weakness · CWE (1)

  • CWE-327 Use of a Broken or Risky Cryptographic Algorithm weakness

References