GitHub Advisoryadvisory · Maven

GHSA-69r9-qgr7-g2wj Apache Tomcat Missing Encryption of Sensitive Data vulnerability

HIGH Published 2026-04-09 Modified 2026-06-08 Official page ↗
Aliases
CVE-2026-34486
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-tribes, org.apache.tomcat:tomcat
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-311
Reviewed
2026-04-10

Affected packages

• Maven org.apache.tomcat:tomcat-tribes: >= 11.0.20, < 11.0.21 → fixed in 11.0.21 • Maven org.apache.tomcat:tomcat-tribes: >= 10.1.53, < 10.1.54 → fixed in 10.1.54 • Maven org.apache.tomcat:tomcat-tribes: >= 9.0.116, < 9.0.117 → fixed in 9.0.117 • Maven org.apache.tomcat:tomcat: >= 11.0.20, < 11.0.21 → fixed in 11.0.21 • Maven org.apache.tomcat:tomcat: >= 10.1.53, < 10.1.54 → fixed in 10.1.54 • Maven org.apache.tomcat:tomcat: >= 9.0.116, < 9.0.117 → fixed in 9.0.117

Description

Missing Encryption of Sensitive Data vulnerability in Apache Tomcat due to the fix for CVE-2026-29146 allowing the bypass of the EncryptInterceptor. This issue affects Apache Tomcat: 11.0.20, 10.1.53, 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.

Related

Alias · CVE (1)

  • CVE-2026-34486 Missing Encryption of Sensitive Data vulnerability in Apache Tomcat due to the fix for CVE-2026-29146 allowing the bypass of the… vulnerability

Weakness · CWE (1)

  • CWE-311 Missing Encryption of Sensitive Data weakness

References