GitHub Advisoryadvisory · Packagist
GHSA-6chf-hhqf-749c Drupal OAuth2 Client Cross-Site Request Forgery (CSRF)
LOW
Official page ↗
- Aliases
- CVE-2025-31684
- Ecosystem
- Packagist
- Packages
- drupal/oauth2_client
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2025-04-02
Affected packages
• Packagist drupal/oauth2_client: < 4.1.3 → fixed in 4.1.3
Description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal OAuth2 Client allows Cross Site Request Forgery. This issue affects OAuth2 Client: from 0.0.0 before 4.1.3.
Related
Alias · CVE (1)
- CVE-2025-31684 Cross-Site Request Forgery (CSRF) vulnerability in Drupal OAuth2 Client allows Cross Site Request Forgery.This issue affects OAuth2 Client:… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness