GitHub Advisoryadvisory · PyPI

GHSA-6cjm-4pxw-7xp9 Sentry vulnerable to leaking superuser cleartext password in logs

HIGH Published 2024-04-18 Modified 2025-09-15 Official page ↗
Aliases
CVE-2024-32474
Ecosystem
PyPI
Packages
sentry
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Weaknesses
CWE-117, CWE-312
Reviewed
2024-04-18

Affected packages

• PyPI sentry: >= 24.3.0, < 24.4.1 → fixed in 24.4.1

Description

Impact When authenticating as a superuser to a self-hosted Sentry instance with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Patches • Self-hosted users on affected versions should upgrade to 24.4.1 or later. • Sentry SaaS users do not need to take any action. This vulnerability is not applicable to SaaS. Workarounds Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or higher. For details on configuring self-hosted Sentry's logging level see our documentation at: https://develop.sentry.dev/config/#logging References • Bug introduced in https://github.com/getsentry/sentry/pull/66393 • Security fix in https://github.com/getsentry/sentry/pull/69148

Related

Alias · CVE (1)

  • CVE-2024-32474 Sentry is an error tracking and performance monitoring platform. vulnerability

Weakness · CWE (2)

  • CWE-117 Improper Output Neutralization for Logs weakness
  • CWE-312 Cleartext Storage of Sensitive Information weakness

References