GitHub Advisoryadvisory · Packagist
GHSA-6v7p-5qcq-268c Zend-Navigation vulnerable to Cross-site Scripting
HIGH
Official page ↗
- Ecosystem
- Packagist
- Packages
- zendframework/zend-navigation
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2024-06-07
Affected packages
• Packagist zendframework/zend-navigation: >= 2.0.0, < 2.2.7 → fixed in 2.2.7
• Packagist zendframework/zend-navigation: >= 2.3.0, < 2.3.1 → fixed in 2.3.1
Description
Many Zend Framework 2 view helpers were using the `escapeHtml()` view helper in order to escape HTML attributes, instead of the more appropriate `escapeHtmlAttr()`. In situations where user data and/or JavaScript is used to seed attributes, this can lead to potential cross site scripting (XSS) attack vectors.
Vulnerable view helpers include:
• All `Zend\Form` view helpers.
• Most `Zend\Navigation` (aka `Zend\View\Helper\Navigation\*`) view helpers.
• All "HTML Element" view helpers: `htmlFlash()`, `htmlPage()`, `htmlQuickTime()`.
• `Zend\View\Helper\Gravatar`
Related
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness