GitHub Advisoryadvisory · Maven
GHSA-72x9-48mc-phh6 Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data
MEDIUM
Official page ↗
- Aliases
- CVE-2022-37023
- Ecosystem
- Maven
- Packages
- org.apache.geode:geode-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2022-09-16
Affected packages
• Maven org.apache.geode:geode-core: < 1.15.0 → fixed in 1.15.0
Description
Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.
Related
Alias · CVE (1)
- CVE-2022-37023 Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness