GitHub Advisoryadvisory · Maven
GHSA-757p-7hp5-pqmr Apache InLong Insufficient Session Expiration vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2023-31065
- Ecosystem
- Maven
- Packages
- org.apache.inlong:manager-pojo, org.apache.inlong:manager-dao, org.apache.inlong:manager-web, org.apache.inlong:manager-service
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-613
- Reviewed
- 2023-07-06
Affected packages
• Maven org.apache.inlong:manager-pojo: >= 1.4.0, < 1.7.0 → fixed in 1.7.0
• Maven org.apache.inlong:manager-dao: >= 1.4.0, < 1.7.0 → fixed in 1.7.0
• Maven org.apache.inlong:manager-web: >= 1.4.0, < 1.7.0 → fixed in 1.7.0
• Maven org.apache.inlong:manager-service: >= 1.4.0, < 1.7.0 → fixed in 1.7.0
Description
Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0.
An old session can be used by an attacker even after the user has been deleted or the password has been changed.
Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 or https://github.com/apache/inlong/pull/7884 to solve it.
Related
Weakness · not in database (1)
Alias · CVE (1)
- CVE-2023-31065 Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0… vulnerability