GitHub Advisoryadvisory · Packagist

GHSA-7c58-g782-9j38 Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI

HIGH Published 2025-05-05 Modified 2025-05-05 Official page ↗
Aliases
CVE-2025-46731
Ecosystem
Packagist
Packages
craftcms/cms
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
Weaknesses
CWE-1336
Reviewed
2025-05-05

Affected packages

• Packagist craftcms/cms: >= 4.0.0-RC1, < 4.14.13 → fixed in 4.14.13 • Packagist craftcms/cms: >= 5.0.0-RC1, < 5.6.15 → fixed in 5.6.15

Description

Craft CMS contains a potential remote code execution vulnerability via Twig SSTI. You must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production Note: This is a follow-up to https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv Users should update to the patched versions (4.14.13 and 5.6.15) to mitigate the issue. References https://github.com/craftcms/cms/pull/17026

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-1336 Improper Neutralization of Special Elements Used in a Template Engine weakness

References