GitHub Advisoryadvisory · Packagist

GHSA-7cvw-wrj9-q5fp Moodle vulnerable to Cross-Site Request Forgery

MEDIUM Published 2022-05-13 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-4133
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
Weaknesses
CWE-352
Reviewed
2025-04-12

Affected packages

• Packagist moodle/moodle: >= 1.9.0, < 1.9.11 → fixed in 1.9.11

Description

Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows remote attackers to hijack the authentication of unspecified victims for requests that modify an RSS feed in an RSS block.

Related

Alias · CVE (1)

  • CVE-2011-4133 Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows remote attackers to hijack the authentication of… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References