GitHub Advisoryadvisory · PyPI

GHSA-7fc2-rm35-2pp7 IPython vulnerable to cross site request forgery (CSRF)

HIGH Published 2022-05-17 Modified 2024-09-27 Official page ↗
Aliases
CVE-2015-5607
Ecosystem
PyPI
Packages
ipython
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2022-06-03

Affected packages

• PyPI ipython: >= 0.12, < 2.4.1 → fixed in 2.4.1 • PyPI ipython: >= 3.0.0, < 3.2.3 → fixed in 3.2.3

Description

IPython (Interactive Python) is a command shell. Cross-site request forgery in the REST API is possible in in IPython 2 and 3. Versions 2.4.1 and 3.2.3 contain patches.

Related

Alias · CVE (1)

  • CVE-2015-5607 Cross-site request forgery in the REST API in IPython 2 and 3. vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References