GitHub Advisoryadvisory · Maven
GHSA-7g95-jmg9-h524 Jenkins cross-site request forgery (CSRF) vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2025-27624
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
- Weaknesses
- CWE-352
- Reviewed
- 2025-03-06
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: >= 2.493, < 2.500 → fixed in 2.500
• Maven org.jenkins-ci.main:jenkins-core: < 2.492.2 → fixed in 2.492.2
Description
Jenkins 2.499 and earlier, LTS 2.492.1 and earlier does not require POST requests for the HTTP endpoint toggling collapsed/expanded status of sidepanel widgets (e.g., Build Queue and Build Executor Status widgets), resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to have users toggle their collapsed/expanded status of sidepanel widgets.
Additionally, as the API accepts any string as the identifier of the panel ID to be toggled, attacker-controlled content can be stored in the victim’s user profile in Jenkins.
Jenkins 2.500, LTS 2.492.2 requires POST requests for the affected HTTP endpoint.
Related
Alias · CVE (1)
- CVE-2025-27624 A cross-site request forgery (CSRF) vulnerability in Jenkins 2.499 and earlier, LTS 2.492.1 and earlier allows attackers to have users… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness