GitHub Advisoryadvisory · Packagist

GHSA-7mg5-rw39-q67f himiklab yii2-jqgrid-widget vulnerable to SQL Injection

CRITICAL Published 2023-01-06 Modified 2023-01-12 Official page ↗
Aliases
CVE-2014-125051
Ecosystem
Packagist
Packages
himiklab/yii2-jqgrid-widget
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2023-01-12

Affected packages

• Packagist himiklab/yii2-jqgrid-widget: < 1.0.8 → fixed in 1.0.8

Description

A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. It has been declared as critical. This vulnerability affects the function `addSearchOptionsRecursively` of the file `JqGridAction.php`. The manipulation leads to sql injection. Upgrading to version 1.0.8 can address this issue. The name of the patch is a117e0f2df729e3ff726968794d9a5ac40e660b9. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217564.

Related

Alias · CVE (1)

  • CVE-2014-125051 A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References