GitHub Advisoryadvisory · Packagist
GHSA-7mqg-5fgh-xh4r MediaWiki Incorrect Access Control vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2019-12472
- Ecosystem
- Packagist
- Packages
- mediawiki/core
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-284
- Reviewed
- 2024-05-15
Affected packages
• Packagist mediawiki/core: >= 1.18.0, < 1.27.6 → fixed in 1.27.6
• Packagist mediawiki/core: >= 1.30.0, < 1.30.2 → fixed in 1.30.2
• Packagist mediawiki/core: >= 1.31.0, < 1.31.2 → fixed in 1.31.2
• Packagist mediawiki/core: >= 1.32.0, < 1.32.2 → fixed in 1.32.2
Description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Related
Alias · CVE (1)
- CVE-2019-12472 An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-12472 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12472.yaml web
- https://github.com/wikimedia/mediawiki package
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html web
- https://phabricator.wikimedia.org/T199540 web