GitHub Advisoryadvisory · Packagist

GHSA-7pjp-fm93-p6pj Cross-Site Request Forgery in moodle

HIGH Published 2024-02-19 Modified 2025-01-23 Official page ↗
Aliases
CVE-2024-25982
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2024-02-21

Affected packages

• Packagist moodle/moodle: >= 4.3.0, < 4.3.3 → fixed in 4.3.3 • Packagist moodle/moodle: >= 4.2.0, < 4.2.6 → fixed in 4.2.6 • Packagist moodle/moodle: < 4.1.9 → fixed in 4.1.9

Description

The link to update all installed language packs did not include the necessary token to prevent a CSRF risk.

Related

Alias · CVE (1)

  • CVE-2024-25982 The link to update all installed language packs did not include the necessary token to prevent a CSRF risk. vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References