GitHub Advisoryadvisory · PyPI

GHSA-7qfw-j7hp-v45g Django WSGI Header Spoofing Vulnerability

MEDIUM Published 2022-05-17 Modified 2024-09-18 Official page ↗
Aliases
CVE-2015-0219
Ecosystem
PyPI
Packages
Django
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-290
Reviewed
2023-08-03

Affected packages

• PyPI Django: < 1.4.18 → fixed in 1.4.18 • PyPI Django: >= 1.6, < 1.6.10 → fixed in 1.6.10 • PyPI Django: >= 1.7, < 1.7.3 → fixed in 1.7.3

Description

Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 allows remote attackers to spoof WSGI headers by using an `_` (underscore) character instead of a `-` (dash) character in an HTTP header, as demonstrated by an `X-Auth_User` header.

Related

Alias · CVE (1)

  • CVE-2015-0219 Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 allows remote attackers to spoof WSGI headers by using an _ (underscore)… vulnerability

Weakness · CWE (1)

  • CWE-290 Authentication Bypass by Spoofing weakness

References