GitHub Advisoryadvisory · PyPI
GHSA-7qqv-r2q4-jxhm privacyIDEA Improper Input Validation vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2018-1000809
- Ecosystem
- PyPI
- Packages
- privacyIDEA
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2020-06-16
Affected packages
• PyPI privacyIDEA: < 2.23.2 → fixed in 2.23.2
Description
privacyIDEA version 2.23.1 and earlier contains a Improper Input Validation vulnerability in token validation api that can result in Denial-of-Service. This attack appear to be exploitable via http request with user=&pass= to /validate/check url. This vulnerability appears to have been fixed in 2.23.2.
Related
Alias · CVE (1)
- CVE-2018-1000809 privacyIDEA version 2.23.1 and earlier contains a Improper Input Validation vulnerability in token validation api that can result in… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000809 advisory
- https://github.com/privacyidea/privacyidea/issues/1227 web
- https://github.com/privacyidea/privacyidea/commit/a3edc09beffa2104f357fe24971ea3211ce40751 web
- https://github.com/advisories/GHSA-7qqv-r2q4-jxhm advisory
- https://github.com/privacyidea/privacyidea package
- https://github.com/pypa/advisory-database/tree/main/vulns/privacyidea/PYSEC-2018-20.yaml web