GitHub Advisoryadvisory · Maven

GHSA-7w75-32cg-r6g2 Apache Tomcat Denial of Service due to improper input validation vulnerability for HTTP/2 requests

MEDIUM Published 2024-03-13 Modified 2025-10-29 Official page ↗
Aliases
CVE-2024-24549
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2024-03-15

Affected packages

• Maven org.apache.tomcat:tomcat-coyote: >= 11.0.0-M1, < 11.0.0-M17 → fixed in 11.0.0-M17 • Maven org.apache.tomcat:tomcat-coyote: >= 10.1.0-M1, < 10.1.19 → fixed in 10.1.19 • Maven org.apache.tomcat:tomcat-coyote: >= 9.0.0-M1, < 9.0.86 → fixed in 9.0.86 • Maven org.apache.tomcat:tomcat-coyote: >= 8.5.0, < 8.5.99 → fixed in 8.5.99 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, < 8.5.99 → fixed in 8.5.99 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0-M1, < 9.0.86 → fixed in 9.0.86 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.19 → fixed in 10.1.19 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.0-M17 → fixed in 11.0.0-M17

Description

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Related

Alias · CVE (1)

  • CVE-2024-24549 Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References