GitHub Advisoryadvisory · Maven

GHSA-825g-mm5v-ggq4 Apache Syncope allows malicious administrators to inject Groovy code

HIGH Published 2025-10-20 Modified 2025-11-05 Official page ↗
Aliases
CVE-2025-57738
Ecosystem
Maven
Packages
org.apache.syncope.core:syncope-core-spring
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-653
Reviewed
2025-10-20

Affected packages

• Maven org.apache.syncope.core:syncope-core-spring: < 3.0.14 → fixed in 3.0.14 • Maven org.apache.syncope.core:syncope-core-spring: >= 4.0.0-M0, < 4.0.2 → fixed in 4.0.2

Description

Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations of a few Java interfaces; such implementations can be provided either as Java or Groovy classes, with the latter being particularly attractive as the machinery is set for runtime reload. Such a feature has been available for a while, but recently it was discovered that a malicious administrator can inject Groovy code that can be executed remotely by a running Apache Syncope Core instance. Users are recommended to upgrade to version 3.0.14 / 4.0.2, which fix this issue by forcing the Groovy code to run in a sandbox.

Related

Alias · CVE (1)

  • CVE-2025-57738 Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations… vulnerability

Weakness · CWE (1)

  • CWE-653 Improper Isolation or Compartmentalization weakness

References