GitHub Advisoryadvisory · crates.io
GHSA-838h-jqp6-cf2f Sandbox bypass leading to arbitrary code execution in Deno
CRITICAL
Official page ↗
- Aliases
- CVE-2022-24783
- Ecosystem
- crates.io
- Packages
- deno
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-269, CWE-863
- Reviewed
- 2022-03-29
Affected packages
• crates.io deno: >= 1.18.0, < 1.20.3 → fixed in 1.20.3
Description
Impact
The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass permission checks and execute arbitrary shell code.
There is no evidence that this vulnerability has been exploited in the wild.
This vulnerability does not affect users of Deno Deploy.
Patches
The vulnerability has been patched in Deno 1.20.3.
Workarounds
There is no workaround. All users are recommended to upgrade to 1.20.3 immediately
---
The cause of this error was that certain FFI operations did not correctly check for permissions. The issue was fixed in this pull request.
Related
Alias · CVE (1)
- CVE-2022-24783 Deno is a runtime for JavaScript and TypeScript. vulnerability
References
- https://github.com/denoland/deno/security/advisories/GHSA-838h-jqp6-cf2f web
- https://nvd.nist.gov/vuln/detail/CVE-2022-24783 advisory
- https://github.com/denoland/deno/pull/14115 web
- https://github.com/denoland/deno/commit/fcfce1bb869fddc629e6d889d6ba1328b80b0dcf web
- https://github.com/denoland/deno package
- https://github.com/denoland/deno/compare/v1.20.2...v1.20.3 web
- https://github.com/denoland/deno/releases/tag/v1.20.3 web