GitHub Advisoryadvisory · Maven

GHSA-83qj-6fr2-vhqg Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT

CRITICAL Published 2025-03-10 Modified 2025-10-22 Official page ↗
Aliases
CVE-2025-24813
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
Weaknesses
CWE-44, CWE-502
Reviewed
2025-03-10

Affected packages

• Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.3 → fixed in 11.0.3 • Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.35 → fixed in 10.1.35 • Maven org.apache.tomcat:tomcat-catalina: >= 9.0.0.M1, < 9.0.99 → fixed in 9.0.99 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.3 → fixed in 11.0.3 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.35 → fixed in 10.1.35 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0.M1, < 9.0.99 → fixed in 9.0.99 • Maven org.apache.tomcat:tomcat-catalina: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, <= 8.5.100 (no fix yet)

Description

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) • support for partial PUT (enabled by default) • a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: • writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-24813 Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added… vulnerability

Weakness · CWE (2)

  • CWE-44 Path Equivalence: 'file.name' (Internal Dot) weakness
  • CWE-502 Deserialization of Untrusted Data weakness

References