GitHub Advisoryadvisory · Maven

GHSA-85wq-pqhp-hmq6 Cross-Site Request Forgery in Jenkins

HIGH Published 2022-05-14 Modified 2022-07-01 Official page ↗
Aliases
CVE-2017-1000356
Ecosystem
Maven
Packages
org.jenkins-ci.main:jenkins-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2022-07-01

Affected packages

• Maven org.jenkins-ci.main:jenkins-core: >= 2.50, < 2.57 → fixed in 2.57 • Maven org.jenkins-ci.main:jenkins-core: < 2.46.2 → fixed in 2.46.2

Description

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an issue in the Jenkins user database authentication realm: create an account if signup is enabled; or create an account if the victim is an administrator, possibly deleting the existing default admin user in the process and allowing a wide variety of impacts.

Related

Alias · CVE (1)

  • CVE-2017-1000356 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an issue in the Jenkins user database authentication… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References