GitHub Advisoryadvisory · Maven

GHSA-86jx-wr74-xr74 Improper escaping in Apache Zeppelin

CRITICAL Published 2024-04-09 Modified 2024-08-21 Official page ↗
Aliases
CVE-2024-31866
Ecosystem
Maven
Packages
org.apache.zeppelin:zeppelin-interpreter
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-116
Reviewed
2024-05-24

Affected packages

• Maven org.apache.zeppelin:zeppelin-interpreter: >= 0.8.2, < 0.11.1 → fixed in 0.11.1

Description

Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2024-31866 Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. vulnerability

Weakness · CWE (1)

  • CWE-116 Improper Encoding or Escaping of Output weakness

References