GitHub Advisoryadvisory · Maven
GHSA-884c-9wwh-9p6v CSRF vulnerability and missing permission checks in Jenkins Publish Over SSH Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-23111
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:publish-over-ssh
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2022-11-29
Affected packages
• Maven org.jenkins-ci.plugins:publish-over-ssh: < 1.23 → fixed in 1.23
Description
A cross-site request forgery (CSRF) vulnerability in Jenkins Publish Over SSH Plugin 1.22 and earlier allows attackers to connect to an attacker-specified SSH server using attacker-specified credentials.
Related
Alias · CVE (1)
- CVE-2022-23111 A cross-site request forgery (CSRF) vulnerability in Jenkins Publish Over SSH Plugin 1.22 and earlier allows attackers to connect to an… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-23111 advisory
- https://github.com/jenkinsci/publish-over-ssh-plugin/commit/21bf41adbce9e71d3f77e113e29bf81d437cadc3 web
- https://github.com/jenkinsci/publish-over-ssh-plugin package
- https://github.com/jenkinsci/publish-over-ssh-plugin/releases/tag/publish-over-ssh-1.23 web
- https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2290 web
- http://www.openwall.com/lists/oss-security/2022/01/12/6 web