GitHub Advisoryadvisory · Packagist

GHSA-88xj-97gf-7wpq Moodle has a CSRF risk in user tours manager that allows tour duplication

LOW Published 2025-04-25 Modified 2025-04-25 Official page ↗
Aliases
CVE-2025-3635
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Weaknesses
CWE-352
Reviewed
2025-04-25

Affected packages

• Packagist moodle/moodle: < 4.1.18 → fixed in 4.1.18 • Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.12 → fixed in 4.3.12 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.8 → fixed in 4.4.8 • Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.4 → fixed in 4.5.4

Description

A security vulnerability was discovered in Moodle that allows anyone to duplicate existing tours without needing to log in due to a lack of protection against cross-site request forgery (CSRF) attacks.

Related

Alias · CVE (1)

  • CVE-2025-3635 A security vulnerability was discovered in Moodle that allows anyone to duplicate existing tours without needing to log in due to a lack of… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References