GitHub Advisoryadvisory · PyPI

GHSA-8f57-wcmg-4jmh Apache Airflow vulnerable to Exposure of Resource to Wrong Sphere

MEDIUM Published 2023-12-21 Modified 2024-11-21 Official page ↗
Aliases
CVE-2023-48291
Ecosystem
PyPI
Packages
apache-airflow
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-668
Reviewed
2023-12-21

Affected packages

• PyPI apache-airflow: < 2.8.0 → fixed in 2.8.0

Description

Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't. This is a missing fix for CVE-2023-42792 in Apache Airflow 2.7.2  Users of Apache Airflow are strongly advised to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability.

Related

Alias · CVE (1)

  • CVE-2023-48291 Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some… vulnerability

Weakness · CWE (1)

  • CWE-668 Exposure of Resource to Wrong Sphere weakness

References