GitHub Advisoryadvisory · Maven

GHSA-8mc5-53m5-3qj2 Apache Tomcat has an Improper Input Validation vulnerability

MEDIUM Published 2026-04-09 Modified 2026-04-15 Official page ↗
Aliases
CVE-2026-32990
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-coyote, org.apache.tomcat:tomcat, org.apache.tomcat.embed:tomcat-embed-core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-20
Reviewed
2026-04-10

Affected packages

• Maven org.apache.tomcat:tomcat-coyote: >= 9.0.113, < 9.0.116 → fixed in 9.0.116 • Maven org.apache.tomcat:tomcat-coyote: >= 10.1.50, < 10.1.53 → fixed in 10.1.53 • Maven org.apache.tomcat:tomcat-coyote: >= 11.0.15, < 11.0.20 → fixed in 11.0.20 • Maven org.apache.tomcat:tomcat: >= 9.0.113, < 9.0.116 → fixed in 9.0.116 • Maven org.apache.tomcat:tomcat: >= 10.1.50, < 10.1.53 → fixed in 10.1.53 • Maven org.apache.tomcat:tomcat: >= 11.0.15, < 11.0.20 → fixed in 11.0.20 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.113, < 9.0.116 → fixed in 9.0.116 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.50, < 10.1.53 → fixed in 10.1.53 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.15, < 11.0.20 → fixed in 11.0.20

Description

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Related

Alias · CVE (1)

  • CVE-2026-32990 Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References