GitHub Advisoryadvisory · Maven, PyPI
GHSA-8rhc-48pp-52gr Apache Spark Deserialization of Untrusted Data vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-12612
- Ecosystem
- Maven, PyPI
- Packages
- org.apache.spark:spark-core_2.11, org.apache.spark:spark-core_2.10, pyspark
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2020-06-16
Affected packages
• Maven org.apache.spark:spark-core_2.11: < 2.1.2 → fixed in 2.1.2
• Maven org.apache.spark:spark-core_2.10: < 2.1.2 → fixed in 2.1.2
• PyPI pyspark: < 2.1.2 → fixed in 2.1.2
Description
In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.1.2, 2.2.0 or later.
Related
Alias · CVE (1)
- CVE-2017-12612 In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness