GitHub Advisoryadvisory · Maven

GHSA-92cc-952p-v8rh Apache Hadoop HDFS Native Client has Out-of-bounds Write Vulnerability

HIGH Published 2026-01-26 Modified 2026-01-26 Official page ↗
Aliases
CVE-2025-27821
Ecosystem
Maven
Packages
org.apache.hadoop:hadoop-hdfs-native-client
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-787
Reviewed
2026-01-26

Affected packages

• Maven org.apache.hadoop:hadoop-hdfs-native-client: >= 3.2.0, < 3.4.2 → fixed in 3.4.2

Description

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. This issue affects Apache Hadoop: from 3.2.0 before 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-27821 Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. vulnerability

Weakness · CWE (1)

  • CWE-787 Out-of-bounds Write weakness

References