GitHub Advisoryadvisory · Packagist

GHSA-93cw-f5jj-x85w Shopware vulnerable to Improper Control of Generation of Code in Twig rendered views

CRITICAL Published 2023-01-17 Modified 2023-01-25 Official page ↗
Aliases
CVE-2023-22731
Ecosystem
Packagist
Packages
shopware/platform, shopware/core
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2023-01-17

Affected packages

• Packagist shopware/platform: < 6.4.18.1 → fixed in 6.4.18.1 • Packagist shopware/core: < 6.4.18.1 → fixed in 6.4.18.1

Description

Impact In Twig environment without the Sandbox extension, it is possible to refer to PHP functions in twig filters like `map`, `filter`, `sort`. This allows in the template to call any global PHP function. Patches The problem has been fixed with 6.4.18.1 with an override of the specified filters until the integration of the Sandbox extension has been finished. Workarounds For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. References https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates

Related

Alias · CVE (1)

  • CVE-2023-22731 Shopware is an open source commerce platform based on Symfony Framework and Vue js. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References