GitHub Advisoryadvisory · Packagist
GHSA-94wq-87g6-8h77 Magento Open Source allows Cross-Site Request Forgery (CSRF)
MEDIUM
Official page ↗
- Aliases
- CVE-2021-39864
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2025-03-04
Affected packages
• Packagist magento/community-edition: >= 2.4.2-p1, <= 2.4.2-p2 (no fix yet)
• Packagist magento/community-edition: 2.4.3 (no fix yet)
• Packagist magento/community-edition: < 2.3.7-p2 → fixed in 2.3.7-p2
• Packagist magento/community-edition: 2.4.2 (no fix yet)
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.2-p2 (and earlier), 2.4.3 (and earlier) and 2.3.7p1 (and earlier) are affected by a cross-site request forgery (CSRF) vulnerability via a Wishlist Share Link. Successful exploitation could lead to unauthorized addition to a customer's cart by an unauthenticated attacker. Access to the admin console is not required for successful exploitation.
Related
Alias · CVE (1)
- CVE-2021-39864 Adobe Commerce versions 2.4.2-p2 (and earlier), 2.4.3 (and earlier) and 2.3.7p1 (and earlier) are affected by a cross-site request forgery… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness