GitHub Advisoryadvisory · Packagist
GHSA-974j-wjxx-wggj Incorrect Access Control vulnerability in api-platform/core
MEDIUM
Official page ↗
- Aliases
- CVE-2019-1000011
- Ecosystem
- Packagist
- Packages
- api-platform/core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-284
- Reviewed
- 2019-09-25
Affected packages
• Packagist api-platform/core: >= 2.2.0, < 2.2.10 → fixed in 2.2.10
• Packagist api-platform/core: >= 2.3.0, < 2.3.6 → fixed in 2.3.6
Description
API Platform version from 2.2.0 to 2.3.5 contains an Incorrect Access Control vulnerability in GraphQL delete mutations that can result in a user authorized to delete a resource can delete any resource. This attack appears to be exploitable via the user must be authorized. This vulnerability appears to have been fixed in 2.3.6.
Related
Alias · CVE (1)
- CVE-2019-1000011 API Platform version from 2.2.0 to 2.3.5 contains an Incorrect Access Control vulnerability in GraphQL delete mutations that can result in… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness