GitHub Advisoryadvisory · RubyGems

GHSA-977c-63xq-cgw3 opensearch-ruby 2.x before 2.0.2 vulnerable to unsafe YAML deserialization

HIGH Published 2022-07-05 Modified 2022-07-21 Official page ↗
Aliases
CVE-2022-31115
Ecosystem
RubyGems
Packages
opensearch-ruby
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2022-07-05

Affected packages

• RubyGems opensearch-ruby: >= 2.0.0, < 2.0.2 → fixed in 2.0.2

Description

Impact A YAML deserialization in opensearch-ruby 2.0.0 can lead to unsafe deserialization using YAML.load if the response is of type YAML. Patches The problem has been patched in opensearch-ruby gem version 2.0.2. Workarounds No viable workaround. Please upgrade to 2.0.2 References https://github.com/opensearch-project/opensearch-ruby/pull/77 https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updated/ For more information If you have any questions or comments about this advisory: • Open an issue in opensearch-ruby

Related

Alias · CVE (1)

  • CVE-2022-31115 opensearch-ruby is a community-driven, open source fork of elasticsearch-ruby. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References