GitHub Advisoryadvisory · Maven

GHSA-998m-f2x3-jjq4 CSRF vulnerability in Jenkins Config File Provider Plugin allows deleting configuration files

MEDIUM Published 2022-05-24 Modified 2023-10-27 Official page ↗
Aliases
CVE-2021-21644
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:config-file-provider
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
Weaknesses
CWE-352
Reviewed
2022-12-13

Affected packages

• Maven org.jenkins-ci.plugins:config-file-provider: < 3.7.1 → fixed in 3.7.1

Description

Jenkins Config File Provider Plugin 3.7.0 and earlier does not require POST requests for an HTTP endpoint, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to delete configuration files corresponding to an attacker-specified ID. This is due to an incomplete fix of SECURITY-938. Jenkins Config File Provider Plugin 3.7.1 requires POST requests for the affected HTTP endpoint.

Related

Alias · CVE (1)

  • CVE-2021-21644 A cross-site request forgery (CSRF) vulnerability in Jenkins Config File Provider Plugin 3.7.0 and earlier allows attackers to delete… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References