GitHub Advisoryadvisory · Maven

GHSA-c264-8834-ppj2 CSRF vulnerability in Jenkins Swarm Plugin

MEDIUM Published 2022-05-24 Modified 2022-12-20 Official page ↗
Aliases
CVE-2020-2192
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:swarm
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
Weaknesses
CWE-352
Reviewed
2022-12-20

Affected packages

• Maven org.jenkins-ci.plugins:swarm: < 3.21 → fixed in 3.21

Description

Swarm Plugin adds API endpoints to add or remove agent labels. In Swarm Plugin 3.20 and earlier these only require a global Swarm secret to use, and no regular permission check is performed. This allows users with Agent/Create permission to add or remove labels of any agent. Additionally, these API endpoints do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Swarm Plugin 3.21 requires POST requests and Agent/Configure permission for the affected agent to these endpoints. It no longer uses the global Swarm secret for these API endpoints.

Related

Alias · CVE (1)

  • CVE-2020-2192 A cross-site request forgery vulnerability in Jenkins Self-Organizing Swarm Plug-in Modules Plugin 3.20 and earlier allows attackers to add… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References