GitHub Advisoryadvisory · Maven

GHSA-c2hg-2jj6-h8vh CSRF vulnerability in Jenkins Pipeline Maven Integration Plugin allow capturing credentials

HIGH Published 2022-05-24 Modified 2022-12-20 Official page ↗
Aliases
CVE-2020-2235
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:pipeline-maven
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Weaknesses
CWE-352
Reviewed
2022-12-20

Affected packages

• Maven org.jenkins-ci.plugins:pipeline-maven: < 3.8.3 → fixed in 3.8.3

Description

Pipeline Maven Integration Plugin 3.8.2 and earlier does not perform a permission check in a method implementing form validation. This allows users with Overall/Read access to Jenkins to connect to an attacker-specified JDBC URL using attacker-specified credentials IDs obtained through another method, potentially capturing credentials stored in Jenkins. Additionally, this form validation method does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Pipeline Maven Integration Plugin 3.8.3 requires POST requests and Job/Configure permission for the affected form validation method.

Related

Alias · CVE (1)

  • CVE-2020-2235 A cross-site request forgery (CSRF) vulnerability in Jenkins Pipeline Maven Integration Plugin 3.8.2 and earlier allows attackers to… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References