GitHub Advisoryadvisory · RubyGems
GHSA-cc8c-26rj-v2vx administrate vulnerable to Cross-Site Request Forgery
MEDIUM
Official page ↗
- Aliases
- CVE-2016-3098
- Ecosystem
- RubyGems
- Packages
- administrate
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-01-27
Affected packages
• RubyGems administrate: < 0.1.5 → fixed in 0.1.5
Description
Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.
Related
Alias · CVE (1)
- CVE-2016-3098 Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness