GitHub Advisoryadvisory · Maven
GHSA-cg6r-gqvc-r396 CSRF vulnerability in GitLab Authentication Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2023-39153
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:gitlab-oauth
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-07-26
Affected packages
• Maven org.jenkins-ci.plugins:gitlab-oauth: < 1.18 → fixed in 1.18
Description
GitLab Authentication Plugin 1.17.1 and earlier does not implement a state parameter in its OAuth flow, a unique and non-guessable value associated with each authentication request.
This vulnerability allows attackers to trick users into logging in to the attacker’s account.
GitLab Authentication Plugin 1.18 implements a state parameter in its OAuth flow.
Related
Alias · CVE (1)
- CVE-2023-39153 A cross-site request forgery (CSRF) vulnerability in Jenkins GitLab Authentication Plugin 1.17.1 and earlier allows attackers to trick… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-39153 advisory
- https://github.com/jenkinsci/gitlab-oauth-plugin/commit/d5bdf767e6be2efa2e9d8f8cf99b98726bb5f29d web
- https://github.com/jenkinsci/gitlab-oauth-plugin web
- https://www.jenkins.io/security/advisory/2023-07-26/#SECURITY-2696 web
- http://www.openwall.com/lists/oss-security/2023/07/26/2 web