GitHub Advisoryadvisory · Maven

GHSA-f4qf-m5gf-8jm8 Apache Tomcat vulnerable to Generation of Error Message Containing Sensitive Information

MEDIUM Published 2024-01-19 Modified 2026-06-18 Official page ↗
Aliases
CVE-2024-21733
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat.experimental:tomcat-embed-programmatic
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-209
Reviewed
2024-01-29

Affected packages

• Maven org.apache.tomcat:tomcat-coyote: >= 9.0.0-M11, < 9.0.44 → fixed in 9.0.44 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.7, < 8.5.64 → fixed in 8.5.64 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0-M11, < 9.0.44 → fixed in 9.0.44 • Maven org.apache.tomcat:tomcat-coyote: >= 8.5.7, < 8.5.64 → fixed in 8.5.64 • Maven org.apache.tomcat.experimental:tomcat-embed-programmatic: >= 9.0.43, < 9.0.44 → fixed in 9.0.44

Description

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.

Related

Alias · CVE (1)

  • CVE-2024-21733 Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7… vulnerability

Weakness · CWE (1)

  • CWE-209 Generation of Error Message Containing Sensitive Information weakness

References