GitHub Advisoryadvisory · Packagist

GHSA-f5pm-c4cw-563p Moodle cross-site request forgery (CSRF) vulnerability

HIGH Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2016-2157
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: < 2.7.13 → fixed in 2.7.13 • Packagist moodle/moodle: >= 2.8.0, < 2.8.11 → fixed in 2.8.11 • Packagist moodle/moodle: >= 2.9.0, < 2.9.5 → fixed in 2.9.5 • Packagist moodle/moodle: >= 3.0.0, < 3.0.3 → fixed in 3.0.3

Description

Cross-site request forgery (CSRF) vulnerability in mod/assign/adminmanageplugins.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote attackers to hijack the authentication of administrators for requests that manage Assignment plugins.

Related

Alias · CVE (1)

  • CVE-2016-2157 Cross-site request forgery (CSRF) vulnerability in mod/assign/adminmanageplugins.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References