GitHub Advisoryadvisory · Packagist
GHSA-f5r8-7h4f-jr9x Moodle incorrect access control
HIGH
Official page ↗
- Aliases
- CVE-2020-25629
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-284, CWE-862
- Reviewed
- 2023-07-13
Affected packages
• Packagist moodle/moodle: >= 3.9, < 3.9.2 → fixed in 3.9.2
• Packagist moodle/moodle: >= 3.8, < 3.8.5 → fixed in 3.8.5
• Packagist moodle/moodle: >= 3.7, < 3.7.8 → fixed in 3.7.8
• Packagist moodle/moodle: >= 3.5, < 3.5.14 → fixed in 3.5.14
Description
A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Related
Alias · CVE (1)
- CVE-2020-25629 A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain… vulnerability