GitHub Advisoryadvisory · Maven

GHSA-f6m8-qm7j-fh65 Apache Kylin Server-Side Request Forgery (SSRF) Vulnerability

HIGH Published 2025-10-02 Modified 2025-11-05 Official page ↗
Aliases
CVE-2025-61735
Ecosystem
Maven
Packages
org.apache.kylin:kylin, org.apache.kylin:kylin-common-server, org.apache.kylin:kylin-common-service, org.apache.kylin:kylin-core-common, org.apache.kylin:kylin-core-metadata, org.apache.kylin:kylin-ops-server, org.apache.kylin:kylin-server
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-918
Reviewed
2025-10-02

Affected packages

• Maven org.apache.kylin:kylin: >= 4.0.0, < 5.0.3 → fixed in 5.0.3 • Maven org.apache.kylin:kylin-common-server: >= 4.0.0, < 5.0.3 → fixed in 5.0.3 • Maven org.apache.kylin:kylin-common-service: >= 4.0.0, < 5.0.3 → fixed in 5.0.3 • Maven org.apache.kylin:kylin-core-common: >= 4.0.0, < 5.0.3 → fixed in 5.0.3 • Maven org.apache.kylin:kylin-core-metadata: >= 4.0.0, < 5.0.3 → fixed in 5.0.3 • Maven org.apache.kylin:kylin-ops-server: >= 4.0.0, < 5.0.3 → fixed in 5.0.3 • Maven org.apache.kylin:kylin-server: >= 4.0.0, < 5.0.3 → fixed in 5.0.3

Description

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected. Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-61735 Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. vulnerability

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References