GitHub Advisoryadvisory · Packagist
GHSA-f9hx-5jq4-fgjm phpMyAdmin CSRF Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-1000499
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2023-07-26
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.7, < 4.7.7 → fixed in 4.7.7
Description
phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.
Related
Alias · CVE (1)
- CVE-2017-1000499 phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000499 advisory
- https://web.archive.org/web/20201208204518/http://www.securitytracker.com/id/1040163 web
- https://www.exploit-db.com/exploits/45284 web
- https://www.phpmyadmin.net/security/PMASA-2017-9 web
- http://cyberworldmirror.com/vulnerability-phpmyadmin-lets-attacker-perform-drop-table-single-click web