GitHub Advisoryadvisory · npm

GHSA-fv66-9v8q-g76r React Server Components are Vulnerable to RCE

CRITICAL Published 2025-12-03 Modified 2025-12-09 Official page ↗
Aliases
CVE-2025-55182
Ecosystem
npm
Packages
react-server-dom-webpack, react-server-dom-turbopack, react-server-dom-parcel
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2025-12-03

Affected packages

• npm react-server-dom-webpack: >= 19.0.0, < 19.0.1 → fixed in 19.0.1 • npm react-server-dom-webpack: >= 19.1.0, < 19.1.2 → fixed in 19.1.2 • npm react-server-dom-webpack: >= 19.2.0, < 19.2.1 → fixed in 19.2.1 • npm react-server-dom-turbopack: >= 19.0.0, < 19.0.1 → fixed in 19.0.1 • npm react-server-dom-turbopack: >= 19.1.0, < 19.1.2 → fixed in 19.1.2 • npm react-server-dom-turbopack: >= 19.2.0, < 19.2.1 → fixed in 19.2.1 • npm react-server-dom-parcel: >= 19.0.0, < 19.0.1 → fixed in 19.0.1 • npm react-server-dom-parcel: >= 19.1.0, < 19.1.2 → fixed in 19.1.2 • npm react-server-dom-parcel: >= 19.2.0, < 19.2.1 → fixed in 19.2.1

Description

Impact There is an unauthenticated remote code execution vulnerability in React Server Components. We recommend upgrading immediately. The vulnerability is present in versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 of: • react-server-dom-webpack • react-server-dom-parcel • react-server-dom-turbopack Patches A fix was introduced in versions 19.0.1, 19.1.2, and 19.2.1. If you are using any of the above packages please upgrade to any of the fixed versions immediately. If your app’s React code does not use a server, your app is not affected by this vulnerability. If your app does not use a framework, bundler, or bundler plugin that supports React Server Components, your app is not affected by this vulnerability. References See the blog post for more information and upgrade instructions.

Related

Alias · CVE (1)

  • CVE-2025-55182 A pre-authentication remote code execution vulnerability exists in React Server Components versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References