GitHub Advisoryadvisory · Maven
GHSA-g4pq-p927-7pgg Jenkins Blue Ocean Plugin cross-site request forgery vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-40341
- Ecosystem
- Maven
- Packages
- io.jenkins.blueocean:blueocean
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-08-16
Affected packages
• Maven io.jenkins.blueocean:blueocean: < 1.27.5.1 → fixed in 1.27.5.1
Description
Jenkins Blue Ocean Plugin 1.27.5 and earlier does not require POST requests for an HTTP endpoint, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to connect to an attacker-specified URL, capturing GitHub credentials associated with an attacker-specified job.
This issue is due to an incomplete fix of SECURITY-2502.
Blue Ocean Plugin 1.27.5.1 uses the configured SCM URL, instead of a user-specified URL provided as a parameter to the HTTP endpoint.
Related
Alias · CVE (1)
- CVE-2023-40341 A cross-site request forgery (CSRF) vulnerability in Jenkins Blue Ocean Plugin 1.27.5 and earlier allows attackers to connect to an… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness