GitHub Advisoryadvisory · Maven

GHSA-g5h3-w546-pj7f Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry

CRITICAL Published 2023-04-20 Modified 2024-07-08 Official page ↗
Aliases
CVE-2023-20873
Ecosystem
Maven
Packages
org.springframework.boot:spring-boot-actuator-autoconfigure
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Reviewed
2023-04-24

Affected packages

• Maven org.springframework.boot:spring-boot-actuator-autoconfigure: >= 3.0.0, < 3.0.6 → fixed in 3.0.6 • Maven org.springframework.boot:spring-boot-actuator-autoconfigure: >= 2.7.0, < 2.7.11 → fixed in 2.7.11 • Maven org.springframework.boot:spring-boot-actuator-autoconfigure: >= 2.6.0, < 2.6.15 → fixed in 2.6.15 • Maven org.springframework.boot:spring-boot-actuator-autoconfigure: < 2.5.15 → fixed in 2.5.15

Description

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

Related

Alias · CVE (1)

  • CVE-2023-20873 In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry… vulnerability

References