GitHub Advisoryadvisory · Maven
GHSA-g5wh-fw4m-2v28 CSRF vulnerability in Jenkins autonomiq plugin
HIGH
Official page ↗
- Aliases
- CVE-2022-25194
- Ecosystem
- Maven
- Packages
- io.jenkins.plugins:autonomiq
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2022-05-04
Affected packages
• Maven io.jenkins.plugins:autonomiq: < 1.16 → fixed in 1.16
Description
Jenkins autonomiq Plugin 1.15 and earlier does not perform a permission check in an HTTP endpoint.
This allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified username and password.
Additionally, this HTTP endpoint does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability.
Related
Alias · CVE (1)
- CVE-2022-25194 A cross-site request forgery (CSRF) vulnerability in Jenkins autonomiq Plugin 1.15 and earlier allows attackers to connect to an… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness