GitHub Advisoryadvisory · Maven
GHSA-g627-r579-rw35 Apache Pulsar: Improper Authorization For Topic-Level Policy Management
MEDIUM
Official page ↗
- Aliases
- CVE-2024-28098
- Ecosystem
- Maven
- Packages
- org.apache.pulsar:pulsar-broker
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2024-03-13
Affected packages
• Maven org.apache.pulsar:pulsar-broker: >= 3.2.0, < 3.2.1 → fixed in 3.2.1
• Maven org.apache.pulsar:pulsar-broker: >= 3.1.0, < 3.1.3 → fixed in 3.1.3
• Maven org.apache.pulsar:pulsar-broker: >= 3.0.0, < 3.0.3 → fixed in 3.0.3
• Maven org.apache.pulsar:pulsar-broker: >= 2.11.0, < 2.11.4 → fixed in 2.11.4
• Maven org.apache.pulsar:pulsar-broker: >= 2.7.1, < 2.10.6 → fixed in 2.10.6
Description
The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role.
This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0.
2.10 Apache Pulsar users should upgrade to at least 2.10.6.
2.11 Apache Pulsar users should upgrade to at least 2.11.4.
3.0 Apache Pulsar users should upgrade to at least 3.0.3.
3.1 Apache Pulsar users should upgrade to at least 3.1.3.
3.2 Apache Pulsar users should upgrade to at least 3.2.1.
Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Related
Alias · CVE (1)
- CVE-2024-28098 The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention,… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness