GitHub Advisoryadvisory · Maven

GHSA-g643-xq6w-r67c Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator.

MEDIUM Published 2024-09-30 Modified 2024-12-12 Official page ↗
Aliases
CVE-2024-45772
Ecosystem
Maven
Packages
org.apache.lucene:lucene-replicator
Severity
Moderate
CVSS vector
CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L
Weaknesses
CWE-502
Reviewed
2024-09-30

Affected packages

• Maven org.apache.lucene:lucene-replicator: >= 4.4.0, < 9.12.0 → fixed in 9.12.0

Description

This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.

Related

Alias · CVE (1)

  • CVE-2024-45772 Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References