GitHub Advisoryadvisory · Maven

GHSA-g9gf-g5jq-9h3v Apache Ranger UI vulnerable to Server Side Request Forgery

CRITICAL Published 2025-01-22 Modified 2026-08-31 Official page ↗
Aliases
CVE-2024-45479
Ecosystem
Maven
Packages
org.apache.ranger:ranger
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-20, CWE-918
Reviewed
2025-01-27

Affected packages

• Maven org.apache.ranger:ranger: >= 0.5.0, < 2.5.0 → fixed in 2.5.0

Description

SSRF vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.

Related

Alias · CVE (1)

  • CVE-2024-45479 SSRF vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-918 Server-Side Request Forgery weakness

References