GitHub Advisoryadvisory · Maven

GHSA-gcx9-497g-6cp6 Apache Tomcat has an Improper Access Control, Incorrect Authorization vulnerability

CRITICAL Published 2026-08-26 Modified 2026-09-02 Official page ↗
Aliases
CVE-2026-65182
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-284
Reviewed
2026-09-02

Affected packages

• Maven org.apache.tomcat:tomcat: >= 11.0.0-M1, < 11.0.25 → fixed in 11.0.25 • Maven org.apache.tomcat:tomcat: >= 10.1.0-M1, < 10.1.58 → fixed in 10.1.58 • Maven org.apache.tomcat:tomcat: >= 9.0.0-M1, < 9.0.121 → fixed in 9.0.121 • Maven org.apache.tomcat:tomcat: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat:tomcat: >= 7.0.0, <= 7.0.109 (no fix yet) • Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.25 → fixed in 11.0.25 • Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.58 → fixed in 10.1.58 • Maven org.apache.tomcat:tomcat-catalina: >= 9.0.0-M1, < 9.0.121 → fixed in 9.0.121 • Maven org.apache.tomcat:tomcat-catalina: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat:tomcat-catalina: >= 7.0.0, <= 7.0.109 (no fix yet) • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.25 → fixed in 11.0.25 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.58 → fixed in 10.1.58 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0-M1, < 9.0.121 → fixed in 9.0.121 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 7.0.0, <= 7.0.109 (no fix yet)

Description

Improper Access Control, Incorrect Authorization vulnerability in Apache Tomcat leads to security constraint bypass if a constraint for a longer path is specified before a more restrictive constraint for a shorter sub-path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.25, 10.1.58, 9.0.121, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2026-65182 Improper Access Control, Incorrect Authorization vulnerability in Apache Tomcat leads to security constraint bypass if a constraint for a… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References